httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Marty Landman <MLand...@face2interface.com>
Subject [users@httpd] newbie suexec quandary
Date Sat, 06 Dec 2003 22:14:35 GMT
I've got Apache 2.0.48 running on FreeBSD 4.8 RELEASE and have been porting 
over a web application of mine. The most recent problem is that the app 
which is written in Perl 5 running as a CGI doesn't always have permission 
to write files to directories.

My understanding is this is a known problem because cgi's run as the id 
that owns httpd which in my case is www; and that suexec is designed to let 
a cgi run as the id that owns the script so that it has the appropriate 
access for what it's doing.

Assuming I'm right so far, here's what I just went through:

#httpd -l
Compiled in modules:
   core.c
   prefork.c
   http_core.c
   mod_so.c

#cd /tmp/httpd-2.0.48
#./configure --enable-suexec --with-suexec-bin=/usr/local/sbin 
--with-suexec-docroot=/mnt/web/guide
#make
#make install

Then httpd -l again with the exact same results! Then tried a graceful 
restart, still the same. The initial Apache install was done using the FBSD 
port and this is my first time attempting to manually recompile Apache. But 
I'll bet you already knew that. :)

/usr/local/apache2/logs/ is empty, the httpd-error.log had no complaints 
during restart. But I notice it restarted Apache/2.0.44 (Unix) so obviously 
I didn't install the newer version. Guess I'll just put on my dunce cap and 
wait in the corner till someone helps straighten me out.


Marty Landman   Face 2 Interface Inc 845-679-9387
Sign On Required: Web membership software for your site
Make a Website: http://face2interface.com/Home/Demo.shtml


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message