httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Carl Barton" <chbar...@phrihawaii.org>
Subject [users@httpd] Redhat Linux > Apache 1.3.27 > reverse Proxy > Exchange 2000 OWA
Date Sat, 13 Dec 2003 02:09:21 GMT
Redhat Linux > Apache 1.3.27 > reverse Proxy > Exchange 2000 OWA

I am having a problem configuring Apache 1.3.27 as a reverse proxy for
Exchange 2000 Outlook
Web Access.  So far I have the Reverse Proxy Working for every IIS site I
have tried except
the one that is running the Exchange 2000 OWA.  The main
two sources I have used in my configuration have been....

http://www.giac.org/practical/Mattison_Ward_GSEC.rtf
http://groups.google.com/groups?q=mod_proxy_add_forward.c&hl=en&lr=&ie=UTF-8&
selm=2prG6.1195%24O7.30461%40news1.mts.net&rnum=4

I wanted to test internally first so I have not set up the Linux/Apache box
on the DMZ.  I have 
used the local hosts file to for all name services.
Because I am just testing internally I also have not set up the Linux/Apache
for SSL.  


Below are some of the relevant files...

HOSTS FILE ON THE REVERSE PROXY SERVER

127.0.0.1	rProxy	localhost.localdomain	localhost
192.168.0.61	owa.phrihawaii.org carl.phrihawaii.org
192.168.0.198	rproxy.phrihawaii.org
192.168.0.61    chb.phrihawaii.org

APACHE httpd.conf FILE  

ProxyRequests Off

ProxyPass /exchange/ http://owa.phrihawaii.org/exchange
ProxyPass /public/ http://owa.phrihawaii.org/public
ProxyPass /exchweb/ http://owa.phrihawaii.org/exchweb
#ProxyPassReverse /exchange/ http://ptexchange1.phrihawaii.org/exchange
#ProxyPassReverse /public/ http://ptexchange1.phrihawaii.org/public
#ProxyPassReverse /exchweb/ http://ptexchange1.phrihawaii.org/exchweb

      
ProxyPass /chb/ http://chb.phrihawaii.org/

HOSTS FILE ON THE CLIENT I AM USING TO TEST

127.0.0.1       localhost
192.168.0.198	owa.phrihawaii.org	
192.168.0.61 	chb.phrihawaii.org


I ALSO compiled the mod_proxy_add_forward.c and THEN LOADED the module in the
httpd.conf

LoadModule proxy_add_forward_module modules/mod_proxy_add_forward.so
AddModule mod_proxy_add_forward.c   # Is this line necessary???...I have it
in now.

I ALSO MADE THE FOLLOWING CHANGES ON THE BACKEND EXCHANGE 2000 AND IIS SERVER

allowed script access for both
allowed anonymous access for ISS server
changed both to Basic Authentication


When I test it form the client using IE 6.  I get a log in prompt from the
IIS / Exchange Server.  
I have verified that the request goes through the reverse proxy and reaches
the IIS / Exchange
Server by watching the traffic from the network monitor.

I log in get 3 attempts to log in and then I get the following error
message...
Error: Access is Denied.

Any ideas that anyone has about this are greatly appreciated.....thanks, Carl


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message