httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Lawson.Adam" <Adam.Law...@ftb.ca.gov>
Subject RE: [users@httpd] FW: (98)Address already in use: make_sock: could not bind to address 158.96.127.173:80 no listening sockets available, shutting down
Date Wed, 03 Dec 2003 23:43:35 GMT
from console, "vi httpd .conf"
edited as follows:
...
user root
group apache
...
 
Result:
Long error when attempting to start httpd service...
<relevant portion of error>
"...!!If you still desire to serve pages as root then!!add -DBIG_SECURITY_HOLE to the CFLAGS
env variable!!and then rebuild the server.!!It is strongly suggested that"... blah  blah
 
I'm afraid I do not know how to do that- I don't recall seeing any environment variable options
when compiling Apache. Would that be what this error is referring to?
 

	-----Original Message----- 
	From: Thomas George [mailto:tgeorge@ibaset.com] 
	Sent: Wed 12/3/2003 3:30 PM 
	To: users@httpd.apache.org 
	Cc: 
	Subject: RE: [users@httpd] FW: (98)Address already in use: make_sock: could not bind to address
158.96.127.173:80 no listening sockets available, shutting down
	
	

	Try running it as 'root'.
	
	-----Original Message-----
	From: Lawson.Adam [mailto:Adam.Lawson@ftb.ca.gov]
	Sent: Wednesday, December 03, 2003 2:49 PM
	To: users@httpd.apache.org
	Subject: [users@httpd] FW: (98)Address already in use: make_sock: could not
	bind to address 158.96.127.173:80 no listening sockets available, shutting
	down
	
	Hello,
	
	        New and enthusiatic (yet frustrated) linux/Apache user with a
	problem I haven't been able to resolve thus far and need help from the
	experts. Please let me know and accept my apologies if this is the wrong
	mailing list for Apache support.
	        
	        Environment:
	        First time linux install, second attempt to run Apache. (Last
	attempt worked with many bugs so I re-installed RH9 and tried again, now
	seeing this problem).
	        I am running RH9 with Apache v2.0.40 binary compiled from scratch
	(.tar.gz) as downloaded and installed following instructs expressly as
	possible by apache.org
	        HTTPD was installed during the RH installation process and the box
	is on a network with PUBLIC IP addresses - this machine 9also with a public
	IP) is the machine on which I am trying to get Apache to run.
	        * Admin'g server using Webmin browser-based admin tool
	        
	        Problem/ Experience Level:
	        ERROR REC'D when trying to start the httpd service:
	        "(98)Address already in use: make_sock: could not bind to address
	158.96.127.173:80 no listening sockets available, shutting down"
	        
	        I cannot start the HTTPD service due to the error message in the
	subject. I am EXTREMELY new to linux and the steps to run an apache
	webserver.
	        
	        Attempted fixes:
	        Re-install Apache (in case I had an old version)
	        Checked http.conf for duplicate Listen directives
	        Set RH Security Level to NO FIREWALL
	        Made sure HTTPD service tries to start at boot-up
	        Deleted all rules form iptables from within Webmin
	(/etc/sysconfig/iptables does not exist)
	        I do not know what else I am missing. Apache just refuses to start.
	Help!
	        
	        AdamL
	        IBM Global Services
	
	
	---------------------------------------------------------------------
	The official User-To-User support forum of the Apache HTTP Server Project.
	See <URL:http://httpd.apache.org/userslist.html> for more info.
	To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
	   "   from the digest: users-digest-unsubscribe@httpd.apache.org
	For additional commands, e-mail: users-help@httpd.apache.org
	
	

Mime
View raw message