httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Lawson.Adam" <Adam.Law...@ftb.ca.gov>
Subject [users@httpd] FW: (98)Address already in use: make_sock: could not bind to address 158.96.127.173:80 no listening sockets available, shutting down
Date Wed, 03 Dec 2003 22:48:32 GMT
Hello,

	New and enthusiatic (yet frustrated) linux/Apache user with a problem I haven't been able
to resolve thus far and need help from the experts. Please let me know and accept my apologies
if this is the wrong mailing list for Apache support.
	 
	Environment:
	First time linux install, second attempt to run Apache. (Last attempt worked with many bugs
so I re-installed RH9 and tried again, now seeing this problem).
	I am running RH9 with Apache v2.0.40 binary compiled from scratch (.tar.gz) as downloaded
and installed following instructs expressly as possible by apache.org
	HTTPD was installed during the RH installation process and the box is on a network with PUBLIC
IP addresses - this machine 9also with a public IP) is the machine on which I am trying to
get Apache to run.
	* Admin'g server using Webmin browser-based admin tool
	 
	Problem/ Experience Level:
	ERROR REC'D when trying to start the httpd service:
	"(98)Address already in use: make_sock: could not bind to address 158.96.127.173:80 no listening
sockets available, shutting down"
	 
	I cannot start the HTTPD service due to the error message in the subject. I am EXTREMELY
new to linux and the steps to run an apache webserver.
	 
	Attempted fixes:
	Re-install Apache (in case I had an old version)
	Checked http.conf for duplicate Listen directives
	Set RH Security Level to NO FIREWALL
	Made sure HTTPD service tries to start at boot-up
	Deleted all rules form iptables from within Webmin (/etc/sysconfig/iptables does not exist)
	I do not know what else I am missing. Apache just refuses to start. Help!
	 
	AdamL
	IBM Global Services

Mime
View raw message