httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Luis Fernando Gallegos Valencia <lfgal...@pichincha.com>
Subject [users@httpd] unable to connect to cgi daemon after multiple tries
Date Thu, 11 Dec 2003 16:48:47 GMT
Hi all, does somebody know how can I solve this problem:

I am doing apache benchmarks on cgis. My cgi program is a simple "hello
world" program.
I run 200 concurrent clients that call the cgi program.
After some time the apache log shows errors like:

 [error] [client 127.0.0.1] (239)Connection refused: unable to connect
to cgi daemon after multiple tries


The client receives an error message like:

<html><head>
<title>503 Service Temporarily Unavailable</title>
</head><body>
<h1>Service Temporarily Unavailable</h1>
<p>The server is temporarily unable to service your
request due to maintenance downtime or capacity
problems. Please try again later.</p>
<hr />
<address>Apache/2.0.48 (Unix) Server at 127.0.0.1 Port 80</address>
</body></html>


When I disabled cgid  and run the test again the error disapeared. That
makes me think cgid has some problem, perhaps in the configuration of
the unix domain sockets accept connection queue.

Can someone tell me how to solve this problem using cgid?

Thanks in advance.

	Luis Gallegos






---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message