httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joshua Slive <jos...@slive.ca>
Subject Re: [users@httpd] Authentication System does not work everytime computer restarts
Date Mon, 03 Nov 2003 18:34:12 GMT

[Plain text please.  Outlook/Word creates some obscenely awful html.]

On Tue, 4 Nov 2003, David wrote:
> I have a question. I managed to get basic authentication for my HTTP
> server up and running.
> However, I notice that everytime I restart my server (or I restart my
> computer), the authentication does not work anymore.

Define "does not work anymore".  What EXACTLY happens?  What do the error
and access log say?

> <Directory "C:/Program Files/Apache Group/Apache2/htdocs/SMA6306">
>
> #AuthUserFile "C:\.htpasswd"

Use forward slashes.

> #AuthName "This is a protected server hosted by David Wong"
> #AuthType Basic
> #Require valid-user

Why is everthing commented out?

>
>             Options None
>             AllowOverride AuthConfig

> I believe using AuthConfig will allow me to use my password file without
> always having to re-create it everytime I restart my server.

AllowOverride affects ONLY .htaccess files.  It has no effect on
httpd.conf.

Joshua.

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message