httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kyle Dent <kd...@seaglass.com>
Subject Re: [users@httpd] apache "forbidden" error accessing my mrtg files
Date Mon, 17 Nov 2003 13:57:14 GMT
On Sun, 16 Nov 2003, Don wrote:

> I'm trying to get Apache to serve up the web pages created by mrtg on my
> Linux/Fedora Core 1 system... but I cant figure out why I get
> "forbidden" errors from httpd...
>
> $ rpm -q httpd mrtg
> httpd-2.0.47-10
> mrtg-2.10.5-1
>
> mrtg runs as a daemon as user mrtg (no special privileges), putting its
> web page files in /home/mrtg/html. mrtg is running fine, I see the files
> get updated regularly.
>
> Apache serves pages from /var/www/html
> so I created a symbolic link called mrtg --> /home/mrtg/html
>
> Apache is configured to "follow symlinks", and in fact I created another
> link in /var/www/html: ln -s ../mrtg mrtgdoc
>
> And when I go to http://localhost/mrtgdoc I get the mrtg doc files
> displayed properly... so "follow links" works
>
> I thought it may have been because there's no index.html file in
> /home/mrtg/html and things weren't set up to allow a directory
> listing.... so I tried looking at a specific file... same error; then I
> created the index.html file ... same error.
>
> What I can't figure out is where is this "forbidden" error coming from?
>
> >From root I also changed permission of /home/mrtg to 755 ... nope, still
> get the 403 error
>
> The documentation for mrtg just says the files have to be in a directory
> "visible to apache".... but it doesn't discuss how that's done ....

What are the permissions on the directory /home/mrtg/html and the
files there?

Kyle


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message