httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sharif Islam <mis...@ux1.cso.uiuc.edu>
Subject [users@httpd] Apache2 + PHP + Red Hat
Date Wed, 26 Nov 2003 20:43:01 GMT

Sorry if this was discussed earlier. I couldn't find any relevant
answers from the archive.

I am currently testing RH Enterprise WS with the following:

httpd-2.0.46-25.ent
httpd-devel-2.0.46-25.ent
freetds-0.61

I uninstalled the php rpm, because I couldn't get freetds(database
connection to mssql server) part working. Then, I got php-4.3.4 and
installed it from scratch with following options:

./configure --with-apxs2=/usr/sbin/apxs --enable-trans-sid
--with-sybase-ct=/usr/local/freetds --with-ldap --with-gd
--with-freetype-dir --with-zlib-dir

I think I made the necessary changes in php.ini(//usr/local/lib/php.ini)
and httpd.conf. However, apache seems to not parsing the php pages. My
test pages work fine in the command prompt, but it spits out the code
as text when I access the pages from a browser.

One other option I can look into is to remove the httpd rpms and build
apache from scratch. However, I would like to avoid that, if I can make
the above work. I would appreciate any pointers. Thanks.

Happy Turkey day.

-Sharif

-- 
Sharif Islam                                         mislam@uiuc.edu
Library Systems Office                     http://www.sharifislam.com
University of Illinois at Urbana-Champaign



---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message