httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Porter, Mark" <Mark.Por...@LibertyMutual.com>
Subject RE: [users@httpd] RewriteRule Strangeness
Date Thu, 06 Nov 2003 17:21:17 GMT
That's got it! I had to escape the % characters in the URL, not just add
the NE.

... just like the doc said. I hang my head in shame.

Thanks for the help!

MP

-----Original Message-----
From: Joshua Slive [mailto:joshua@slive.ca] 
Sent: Thursday, November 06, 2003 11:35 AM
To: users@httpd.apache.org
Subject: Re: [users@httpd] RewriteRule Strangeness



On Wed, 5 Nov 2003, Porter, Mark wrote:
> Hitting http://www.site.com/auto, I'm redirected to the long path in
the
> rule... almost. The redirect is stripping out the %2 characters, so I
> end up here:

Have you tried the "NE" flag to RewriteRule?  (See the mod_rewrite
docs.)

Joshua.

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server
Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message