httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Fred Scheifele <apa...@Scheif.net>
Subject [users@httpd] Problem with Form Processing in PHP
Date Tue, 11 Nov 2003 20:18:30 GMT
Greetings, all.

I am relatively new to Apache and have been lurking here for a few 
weeks.  This is my first post.

I am having a problem processing forms in PHP.  I know this is not a PHP 
list, but I have investigated this problem from the PHP side, and I 
can't find anything wrong (although I am relatively new to PHP, as well.)

I'll get to the symptoms in a second, but first let me give some quick 
background.  My production Web site is on a commercial server running 
Apache 1.3.28 and PHP 4.3.3 on Linux.  My site is one of many virtual 
hosts served by this machine, and I do not have access to httpd.conf  I 
can use .htaccess files freely, though.  I have a test server (my 
desktop machine) running Apache 2.0.47 and PHP 4.3.3 on Windows XP Pro. 
Obviously, I have access to httpd.conf on the test server.

Now, the symptom.  Form processing works correctly on my test server, 
but on the production server, the $_POST super-global array is not 
populated with my form data.  (If I submit using GET, the $_GET array is 
empty.)

And finally, my question.  Are there any Apache directives that could 
cause this?  I have looked through the documentation, but my 
inexperienced eyes did not find anything.

I can post a small test form and action script if it will help.

Thanks in advance for any help.

-- 

Cheers,
  Fred Scheifele
  http://www.Scheif.net/


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message