httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Lars Hecking <lheck...@nmrc.ucc.ie>
Subject [users@httpd] Unresolved symbols on Solaris
Date Thu, 20 Nov 2003 17:10:14 GMT

 Solaris 9 8/03 SPARC
 gcc 2.95.3
 Solaris /usr/ccs/bin compiler tools
 apache 1.3.29/mod_ssl-2.8.16-1.3.29/openssl-0.9.7c/mm-1.1.3

 I am configuring/building/installing apache exactly the same way as always.
 All works fine under Solaris 8 (same machine), but not Solaris 9:

# ./apachectl start
Syntax error on line 205 of /usr/local/apache/conf/httpd.conf:
Cannot load /usr/local/apache/libexec/mod_mmap_static.so into server: ld.so.1: /usr/local/apache/bin/httpd:
fatal: relocation error: file /usr/local/apache/libexec/mod_mmap_static.so: symbol ap_null_cleanup:
referenced symbol not found
./apachectl start: httpd could not be started

 I tried compiling all modules statically into the server, no dso support,
 but ran into problems with mod_layout.

 A Google search did not produce anything helpful.

 Any ideas? I have apache2 running successfully on a Solaris 9 box, but the
 web site in question needs some rework to be usable with it (modules, local
 scripts and cgi).


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message