httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joshua Daniel Franklin <joshuadfrank...@yahoo.com>
Subject [users@httpd] How to use AddModule
Date Thu, 20 Nov 2003 00:42:47 GMT
I have an apache-1.3 server that is loading various modules.
The httpd.conf has several LoadModule statements but no
AddModule ones, and it works fine. However, I see AddModule
recommended various places. The documentation is rather vague
on the point. For LoadModule, for example:
<http://httpd.apache.org/docs/mod/mod_so.html#loadmodule>
"The LoadModule directive links in the object file or library
filename and adds the module structure named module to the list of active 
modules."
But then for AddModule:
<http://httpd.apache.org/docs/mod/core.html#addmodule>
"This directive can be used to enable the use of those modules."

What is the difference between an active module and an enabled module?
It sounds like LoadModule loads the actual object file from disk.
Does apache keep track of whether loaded modules disabled/enabled in memory?
Does the very first connection, for example, enable setenvif_module?

And, the question most to the point, is there a performance difference when
using AddModule?
Thanks.

__________________________________
Do you Yahoo!?
Protect your identity with Yahoo! Mail AddressGuard
http://antispam.yahoo.com/whatsnewfree

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message