httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Marcus Collier" <mar...@staff.highway1.com.au>
Subject [users@httpd] child seg faults with mod_usertrack on 1.3.29
Date Wed, 12 Nov 2003 03:10:26 GMT
Hi,

As soon as I enable 'CookieTracking On' on any Virtual Server, the site
stops working except for the default page.  All other
images/stylesheets/html, etc will fail to load.

In the error Log I get:
[Wed Nov 12 10:24:21 2003] [notice] child pid 1592 exit signal
Segmentation Fault (11)
[Wed Nov 12 10:25:35 2003] [notice] child pid 3024 exit signal
Segmentation Fault (11)

The server is an Apache 1.3.29 server with PHP 4.3.4 (dynamically
linked) running on Solaris 8 & 9.  I've now tried this on a variety of
servers, and the bug seems to only affect version 1.3.29. 1.3.28 worked
fine.

Just some things that I haven't ruled out, is that all installs have
been upgrades, I am yet to install in a new location to rule out old
files playing havoc.

My Apache was configured with:
./configure \
"--with-layout=Apache" \
"--prefix=/usr/local/apache" \
"--enable-shared=max" \
"--enable-module=most" \
"--enable-module=so" \
"--enable-suexec" \
"--suexec-caller=***" \
"--suexec-docroot=***"

<VirtualHost *****>
ServerAdmin marcus@highway1.com.au
DocumentRoot ***/html
ServerName marcus.highway1.com.au
CookieTracking On
CustomLog ****-access_log usertrack
ErrorLog ****-error_log
ScriptAlias /cgi-bin/ ****/cgi-bin/
</VirtualHost>

There seems to have been numerous 'bug fixes' to the mod_usertrack
module in the latest release.

Thanks,
Marcus.


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message