httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joshua Slive <jos...@slive.ca>
Subject Re: [users@httpd] User/Group specification in virtual host not working with suEXEC
Date Sun, 05 Oct 2003 18:40:31 GMT

On Sun, 5 Oct 2003, John Wilcox wrote:
> So I tried adding a "User john" and "Group john"
> directive inside my VirtualHost listing, to override
> the default user/group of nobody/nogroup, but when I
> point my browser to the virtual host, as in
> http://test.domain.com/showuser.cgi, I get a "500
> Internal Server Error" with the corresponding message
> in my log file: "[Sun Oct  5 14:32:42 2003] [error]
> [client 192.168.0.2] Premature end of script headers:
> /home/test/showuser.cgi"

Now you need to look in the suexec log file to see exactly what suexec
policy you are violating.  Unfortunately, since you are using such an old
version, I can't help you find the suexec log file.  In new versions, you
can ask suexec where the log file is.

In the worst-case scenario where you can't find the log, you have two
choices: get a new version of apache and properly configure the location
of the suexec log; or go through the suexec docs and carefully check each
policy.  Some likely culprits include having a group-writable parent
directory or not being in the --suexec-docroot specified when suexec was
compiled.

Joshua.

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message