httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Boyle Owen" <Owen.Bo...@swx.com>
Subject RE: [users@httpd] FW: uploading files using apache 1.3.2 > 1MB
Date Wed, 22 Oct 2003 08:50:14 GMT
Plain text - PLEEEEZ...

We have a website where users upload files to our SSL server using this
mechanism. Testing locally, we demonstrated uploads of up to 20 MB
before we got fed up (the original spec was for files of around a few
100Kb). All went well in production for about six months until one
customer started getting failures... when his filesize went above
1MB!!!!

We finally tracked the problem down to an SSL hardware accelerator that
we had in the production DMZ. This machine happened to have a software
limit on upload filesizes which was set by default to 1MB. As soon as it
saw a Content-length of greater than 1048576, it dropped the packet. We
switched the limit to 20MB and all was well again.

Do you have some gizmo (bridge, router, firewall, load balancer..)
between your server and the WWW? If so, read it's fine manual and see if
it doesn't have a built-in limit on incoming packets.

Rgds,
Owen Boyle
Disclaimer: Any disclaimer attached to this message may be ignored. 

-----Original Message-----
From: Malcolm Bovis [mailto:malcolm.bovis@cognitionsolutions.com]
Sent: Dienstag, 21. Oktober 2003 18:43
To: users@httpd.apache.org
Subject: [users@httpd] FW: uploading files using apache 1.3.2 > 1MB


 
 


Hi, I'm trying to upload files > 1MB using form enctype mutipart/data,
and all goes fine until just under 1MB.

I can upload multiple files at once less than 800kb in total and all
stays well, yet when I try and upload 1 or more larger files, I.E gives
me the page "Action Canceled", this means that it doesnt even get to the
cgi script!!!! 

 I wrote the cgi script to upload files myself, and its a first for me
so thought I'd use someone else's to test it (psupload), as it claimed
to be capable of 500MB+, yet I get the same problem...

This leads me to believe it may be a server problem...

I have looked around forums and mailing lists, and see that this is a
problem for many users using PHP and Apache (and have therefore
discovered solutions for PHP, Cold Fusion and another), but I cannot
find any solutions for my particular problem, I have also looked at the
LimitRequestBody but it is not in my conf files anyway, and I've tried
adding it.
Any ideas would be greatly appreciated...!

Thx












 
Malcolm Bovis 
Cognition Solutions, Fairview Court
119-127 Fairview Road, Cheltenham, GL52 2EX.
Tel:01242 244014
website  |  email

This message is for the named person's use only. It may contain
confidential, proprietary or legally privileged information. No
confidentiality or privilege is waived or lost by any mistransmission.
If you receive this message in error, please notify the sender urgently
and then immediately delete the message and any copies of it from your
system. Please also immediately destroy any hardcopies of the message.
You must not, directly or indirectly, use, disclose, distribute, print,
or copy any part of this message if you are not the intended recipient.
The sender's company reserves the right to monitor all e-mail
communications through their networks. Any views expressed in this
message are those of the individual sender, except where the message
states otherwise and the sender is authorised to state them to be the
views of the sender's company. 



---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message