httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Satya Narayan Dash" <ndsa...@rediffmail.com>
Subject [users@httpd] Directory Index not working - Apache 2.0.47
Date Wed, 22 Oct 2003 17:43:19 GMT
<P>
Hi All,<BR>
<BR>
I posted this question a week ago and after some interactions in the group I thought I have
a problem in my configurations. But after a lot of try cum trial-error I feel it is an issue
with Apache. Before filing a bug, I want to confirm my problem from you.<BR>
<BR>
I have Apache2.0.47-Tomcat 4.1.27 connected by mod_jk. <BR>
<BR>
I httpd.conf, I have configured ServerRoot, ServerName, DocumentRoot, DirectoryIndex(same
as that of DocumentRoot), and mod_jk info.<BR>
<BR>
My directory index is jsp/Welcome.jsp. <BR>
<BR>
However, instead of showing the Welcome JSP file, it shows me the directories in the Document
Root. But if I am putting a HTML page is put as directory index, it comes properly. But no
JSP page.<BR>
<BR>
If i am putting directory index as /jsp/ Wecome.jsp, the page comes , but it takes more than
40secs. Please note the &lt;SPACE&gt;. I have precompiled classes (compiled with Tomcat4.1.27).
(so a bit of frustration in this sort).<BR>
<BR>
For mod_jk related, my Jkmount config is <BR>
<BR>
JkMount /*.jsp ajp13<BR>
<BR>
Please let me know, if I have a mistake somewhere. <BR>
<BR>
My sincere thanks for your help,<BR>
Satya.<BR>
<BR>
<BR>
<BR>
<BR>

</P>
<br><br>
<A target="_blank" HREF="http://clients.rediff.com/signature/track_sig.asp"><IMG
SRC="http://ads.rediff.com/RealMedia/ads/adstream_nx.cgi/www.rediffmail.com/inbox.htm@Bottom"
BORDER=0 VSPACE=0 HSPACE=0 HEIGHT=74 WIDTH=496></a>

Mime
View raw message