httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dan Trainor <d...@cavecreek.net>
Subject Re: [users@httpd] apache hangs when getting pages from win2k
Date Wed, 29 Oct 2003 13:49:55 GMT
I'm not too keen on Win32 Apache, but is there an option in there where
it tries to do reverse lookups of clients, or domain resolutions of
clients?  It's very difficult *cough* to do a resolution of 127.0.0.1 or
something like that... hunt for that option and turn it off, if such a
beast exists.

-dant



On Wed, 2003-10-29 at 06:46, Oliver Schoenborn wrote:
> Hi, I have the exact same problem as described a week ago in another thread, but that
thread didn't seem to come to a solution, hard to say because I found it in the archives before
subscribing to the list. 
> 
> In any case, the situation is this: 
>   a.. Latest apache (2.0.47) on Win2k Pro latest service pack/patches etc
>   b.. Default configuration file httpd.conf, with ServerName localhost, explicit ip,
or 127.0.0.1, tried them all 
>   c.. Running apache -t says no syntax errors
>   d.. Apache runs
>   e.. If I try http://localhost/ or http://127.0.0.1/ or http://192.168.2.2/, the browser
just keeps waiting forever (never stops, tried leaving overnight)
>   f.. I checked with netstate -an that no other process is using port 80 before starting
apache
>   g.. I can also see when attempting to get a page that the connection on port 80 is
active (i.e., netstat -an shows two new entries, one for 127.0.0.1:80 and one for 127.0.0.1:N
where N is the port used, presumably, by MSIE)
>   h.. Set LogLevel to debug and find the error message "child.c(547): (OS 10038)An operation
was attempted on something that is not a socket.  : winnt_accept: AcceptEx failed due to early
client disconnect. Reallocate the accept socket and try again", over and over again in error.log
>   i.. Disabled McAfee VirusScan during install of apache and before starting Apache,
but doesn't help
>   j.. If I put the wrong port number (say I do http://localhost:809) I immediately get,
as expected, a server not found error
> The one thing I do dread trying is removing McAfee, because if that doesn't help, re-installing
it will be a major pain (plus, the removal may not fix any damage already done, based on some
info I found on the net, about corrupted tcp/ip stack, plus, it was apparently fixed in apache
version 2.0.44). 
> 
> Does anyone know the solution to this, or other things I can try to figure out the problem?
I think perhaps there's something not setup right in "Internet Options", perhaps security
levels or WINS? I don't know much about those so it's hard to know what to look for. Thanks
for any info, 
> 
> Oliver
-- 
Dan T.
Cavecreek Systems Administration Team
http://www.cavecreek.net

24 hour technical support
support@cavecreek.net
480.449.7750

------------------------------------------------------------
We welcome feedback on your customer service experience.
Please send a message to qc@cavecreek.net
------------------------------------------------------------



---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message