httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jan Mattila <jan.matt...@helsinki.fi>
Subject [users@httpd] httpd-2.0.47 - Unable to run in chroot jail - fixed
Date Mon, 13 Oct 2003 11:14:25 GMT
Hello.

I posted to the list on October 2nd about a problem with 
running Apache2 in a chroot jail.

The error message I got was this:

[crit] (5)Input/output error: apr_proc_detach failed 
Pre-configuration failed


The problem was fixed by changing the setting of /dev/null 
in the chroot jail.

The commands for the mknod that worked were:

mknod /chroot/something/dev/null c 1 3
chmod 666 /chroot/something/dev/null


Werner: I know your error message was not the same, but 
it still seemed like it might have to do with the /dev/null. 
You could try comparing the /dev/null outside your jail to 
the one inside it (if the httpd outside the jail works, 
that is). That's how I found the right settings.

-- 

 Jan Mattila <jan.mattila@helsinki.fi>

 "Finland, Finland, Finland, Finland has it all."
                             - Michael Palin

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message