httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Leif W" <warp-...@usa.net>
Subject Re: [users@httpd] Apache2 upgrade + smb mount + symbolic link = zero byte downloads
Date Fri, 24 Oct 2003 13:56:52 GMT
Maybe it's a permissons error?  Are you sure all the files have the correct
permissions on the win2k side?  That the share is mounted with correct
permissions on the linux side?  Try copying a file from the share to the
linux filesystem.  See if you can do that.

Leif

----- Original Message ----- 
From: "Rob Rosenfeld" <rosenfeld@alum.mit.edu>
To: <users@httpd.apache.org>
Sent: Friday, October 24, 2003 4:27 AM
Subject: RE: [users@httpd] Apache2 upgrade + smb mount + symbolic link =
zero byte downloads


Thanks for the reply.

> -----Original Message-----
> From: Leif W [mailto:warp-9.9@usa.net]
>
> Then I do this in the VirtualHost:
>
>     Alias "/music" "/mnt/mp3"
>     <Directory "/mnt/mp3">
>         # You may or may not be interested in this:
>         Options Indexes
>         ...
>     </Directory>
>

I have tried this approach.  The Alias works.  With Options Indexes I can
browse the directories and get the proper file info, but when I try to
actually download an MP3 file, I still get a 200 OK zero-byte file as shown
in the wget example below from my prior post.  I guess this does rule out it
having to do anything with the symbolic links though.

If the alias points to a directory of MP3's on a local file system, I can
download the file.  I only have this problem when the file to be downloaded
in on the smbfs network mount.

>
> PROMPT $ wget http://www.mydomain.com/music/goodmusic.mp3
> --00:39:44--  http://www.mydomain.com/music/goodmusic.mp3
>            => `goodmusic.mp3'
> Resolving www.mydomain.com... done.
> Connecting to www.mydomain.com[xxx.xxx.xxx.xxx]:80... connected.
> http request sent, awaiting response... 200 OK
> Length: 3,264,370 [audio/mpeg]
>
>  0% [               ] 0             --.--K/s    ETA --:--
>
> 00:39:44 (0.00 B/s) - Connection closed at byte 0. Retrying.
>


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org





---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message