httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Dave Brooks" <mal...@twcny.rr.com>
Subject [users@httpd] Help needed with Apache 2 on RH9
Date Mon, 20 Oct 2003 22:47:12 GMT
Hi there...

Well, this is a last-ditch effort.  I've been working on this for days and I
don't seem to be getting anywhere.
I hope someone will have some insight to offer.

A short time back, I migrated from RH7.2 to 9.0 and upgraded to Apache 2
from the 1.3 series. So as not to mislead anyone...I didn't simply "upgrade"
existing systems...I actually built a new box, did the installations and
then migrated data.


Ever since the upgrade I have been unable to configure apache to allow users
their own cgi-bin. The user web space works fine, a few users are running
web sites without any issues, this is strictly a cgi-bin issue:

Any cgi moved to any user cgi-bin fails to run with the following error
logged:

quote:
----------------------------------------------------------------------------
----
[Sun Oct 19 11:56:10 2003] [error] [client *.*.*.*] Premature end of script
headers: testme.cgi
----------------------------------------------------------------------------
----
(I edited out the IP for this post, that's not in the log like that)


Now... I can take the SAME *.cgi and mv it to the server's cgi-bin and it
works fine.   This tells me that I have the applicable "\n\n" in the proper
place and is not truly the normal header issue.  Also, I can execute the cgi
in the cgi-bin from command line, so I can rule out faulty code.  I should
also mention that I only work with C or C++ cgi's, so paths to perl or bash
are irrelevant.

To rule out permission issues, I chmod'd to 777  (both the cgi and the
directory
the owner of the bin is the user and the group is the httpd group

here are the applicable entries in the config:
quote:
----------------------------------------------------------------------------
----

<IfModule mod_userdir.c>
UserDir WWW
UserDir disabled root
</IfModule>

<Directory /home/*/WWW>
AllowOverride FileInfo AuthConfig Limit
Options MultiViews Indexes SymLinksIfOwnerMatch
<Limit GET POST OPTIONS>
Order allow,deny
Allow from all
</Limit>
<LimitExcept GET POST OPTIONS>
Order allow,deny
Allow from all
</LimitExcept>
</Directory>

<Directory /home/*/WWW/cgi-bin>
Options ExecCGI
AddHandler cgi-script .cgi .pl
</Directory>

----------------------------------------------------------------------------
----

*someone mentioned that the "Options ExecCGI" line should actually read as:
"Options +ExecCGI",
but that didn't seem to make any difference.


I've been banging my head against the wall with this for a couple days now,
if anyone has any suggestions it would be greatly appreciated.

Thanks

Dave
malloc@twcny.rr.com
----------------------------------------------------------------------------
-----
DevBox : An Open Community Development Server
http://www.devbox.us


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message