httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jesse Guardiani <je...@wingnet.net>
Subject [users@httpd] apache 1.3.28 and zombie CGI processes
Date Tue, 23 Sep 2003 17:26:30 GMT
Howdy list,

I run a FreeBSD 4.8-RELEASE box in a production environment.

Last Friday I upgraded the Apache build from 1.3.27 to 1.3.28,
and I instantly started seeing zombie sqwebmail processes
collect on the server. (sqwebmail is a webmail CGI app written
in C)

By Monday morning (09/22/03), I had 36 sqwebmail zombies on my
server. `apachectl graceful` got rid of the zombies, but they
keep coming back.

I have discussed this problem on the sqwebmail list and others
have confirmed the same problem on the same operating system and
at least one other operating system: Linux RedHat 8.0

Downgrading Apache to 1.3.27 solves the problem, so I'm pretty
sure it's an Apache issue at this point.

One member of the sqwebmail list said that some changes were
made between 1.3.27 and 1.3.28 with regard to CGI handling.

Is this true?
What files were effected?

I'm hoping someone else can come up with a quick solution to
this bug for me, but if necessary I'd be willing to take a look
at the code myself if I knew where to start.

Thanks.

-- 
Jesse Guardiani, Systems Administrator
WingNET Internet Services,
P.O. Box 2605 // Cleveland, TN 37320-2605
423-559-LINK (v)  423-559-5145 (f)
http://www.wingnet.net



---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message