httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Brian Dessent <br...@dessent.net>
Subject Re: [users@httpd] Apache doesn't display pictures
Date Sun, 14 Sep 2003 10:35:19 GMT
Haris Kazic wrote:
> 
> ok i checked it again.
> 
> it says cannot open /usr/local/etc/apache/mime.types directory..
> 
> ----- Original Message -----
> From: "Haris Kazic" <haris@haris.demon.nl>
> To: <users@httpd.apache.org>
> Sent: Sunday, September 14, 2003 12:13 PM
> Subject: Re: [users@httpd] Apache doesn't display pictures
> 
> > Ok there is a log file, but no error in it.
> > About accesing the p[ictures directly:
> >
> > example:
> >
> > http://192.168.1.34/banner.jpg

Okay, two things.

1. mime.types is a file that should have been installed when you did the
"make install" command.  You might have a "mime.types-dist" (or similar)
file instead, which is the name of the default file.  This is done so
that if you have any customizations they are not lost when you
reinstall.  In any case, if you don't have a mime.types file you should
copy mime.types-dist to mime.types.

2. If you are doing any kind of name-based virtual hosting then
referring to a URL with an IP address (instead of a hostname) will not
work.  The browser has to ask for the resource by name in order for
apache to know which virtual host it's referring to.

Brian

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message