httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From j...@rahul.net (Jeff Lacki)
Subject [users@httpd] POST turns into GET problem
Date Mon, 29 Sep 2003 04:55:46 GMT

Hi-

Im running redhat 9.0 with apache 2.0.47

I have the following html file:

<html>
<head>
<body>
    <center>
    <h2>
    <form method="POST" action="http://www.ptsdsurvey.com/cgi-bin/mil_civ.pl">
        <input type="hidden" name="mil_civ" value="military">
        <input type="image" src="http://www.ptsdsurvey.com/mil_button.jpg" alt="Military">
    </form>
    <form method="POST" action="http://www.ptsdsurvey.com/cgi-bin/mil_civ.pl">
        <input type="hidden" name="mil_civ" value="civilian">
        <input type="image" src="http://www.ptsdsurvey.com/civ_button.jpg" alt="Civilian">
    </form>
</body>
</html>


When you click on either image, instead of POSTing, the REQUEST_METHOD
ends up as a GET instead of a POST

I havent done anything fancy to my httpd.conf file at all, its nearly
close to standard as I installed it.

By the way, this happens only on computers (on my home network 192.168.1.x)
and not on the RH9 server itself....on that server, it works correctly.

If you try it yourself (http://www.ptsdsurvey.com) you should also
get an error page (that I send back) saying that it got a GET and not
a POST.

Any suggestions/help is greatly appreciated!
Thanks,
Jeff


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message