httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Robert Andersson" <rob...@profundis.nu>
Subject Re: [users@httpd] PHP Problems
Date Tue, 16 Sep 2003 09:09:38 GMT
Joseph A Nagy Jr wrote:
> I am running Apache 2.0.40 with mod_php intalled and loaded, yet when I
> go here:
>
> http://jan-jr-ent.homelinux.org/php/
>
> It displays as plain text. I also have
>
> <Files *.php>
>     SetOutputFilter PHP
>     SetInputFilter PHP
>     LimitRequestBody 524288
> </Files>


I may be out of touch here, but PHP as input filter??? AFAIK PHP do not do
this; at least, I cannot see the point. What are you trying to accomplish by
using this, rather than the conventional AddType, setup? Have you
read/follow the installation instructions bundled with PHP?

> 192.168.1.1 - - [15/Sep/2003:21:23:40 -0500] "GET /php/ HTTP/1.1" 200
> 5155 "-" "Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1
> .5b) Gecko/20030827"

Did you expect anything else here? I assume you have an index.php in that
directory, which Apache apparently send as plain/text. This may be because
your <Files> block may not match an indirect directory index file?

I suggest you try this line instead:

    AddType application/x-httpd-php .php .phtml

Regards,
Robert Andersson


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message