httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Randip Kumar MALAKAR <randip.mala...@st.com>
Subject [users@httpd] LDAP authentication in APACHE fails
Date Wed, 10 Sep 2003 15:48:29 GMT
Hi,
     I am unable to authenticate apache (Apache/2.0.47 Solaris 8 SPARC) through LDAP (using
.htaccess).  But if I remove .htaccess
(without authentication)  from Document directory, my server works fine.

my error log shows "child pid 783 exit signal Bus error (10)" as shown below (when I use .htaccess):


# tail error_log

[Wed Aug 20 11:08:35 2003] [notice] LDAP: Built with OpenLDAP LDAP SDK
[Wed Aug 20 11:08:35 2003] [notice] LDAP: SSL support unavailable
[Wed Aug 20 11:08:44 2003] [notice] LDAP: Built with OpenLDAP LDAP SDK
[Wed Aug 20 11:08:44 2003] [notice] LDAP: SSL support unavailable
[Wed Aug 20 11:08:45 2003] [notice] Apache/2.0.47 (Unix) configured -- resuming normal operations
[Wed Aug 20 11:09:40 2003] [notice] child pid 783 exit signal Bus error (10)

My server is compiled with mod_Auth_ldap statically. I am using Openldap SDK.

# ./httpd -l
Compiled in modules:
  core.c
  mod_access.c
  mod_auth.c
  util_ldap.c
  mod_auth_ldap.c
  mod_include.c
  mod_log_config.c
  mod_env.c
  mod_setenvif.c
  prefork.c
  http_core.c
  mod_mime.c
  mod_status.c
  mod_autoindex.c
  mod_asis.c
  mod_cgi.c
  mod_negotiation.c
  mod_dir.c
  mod_imap.c
  mod_actions.c
  mod_userdir.c
  mod_alias.c
  mod_so.c
#

I have searched for any help in google/yahoo, but could not find any solutions.

PLEASE HELP/SUGGEST

Thanks in advance

Regards
Randip


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message