httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Frank McCreedy" <mccre...@bellsouth.net>
Subject Re: [users@httpd] problem compiling 2.0.47 on windows
Date Thu, 18 Sep 2003 05:41:43 GMT
Hate to answer my own question but in case someone else runs into this:

flex.exe was inserting the #include <unistd.h> into the .c file.  Turns out
the cygwin flex I was using was not the latest, upgrading it fixed the
problem (I wonder why cygwin installer doesn't give the latest packages?)

Thanks,

Frank

----- Original Message ----- 
From: Frank McCreedy
Subject: [users@httpd] problem compiling 2.0.47 on windows

Trying to compile 2.0.47 with SSL on windows 2000 using Visual Studio 6.
All goes well until

ssl_expr_scan.c
lex.ssl_expr_yy.c(602) : fatal error C1083: Cannot open include file:
'unistd.h': No such file or directory

>From what I've read "#include <unistd.h>" should be taken out when
configured on windows, but it looks like it isn't happening to
ssl_expr_scan.c

I'm pretty ignorant with c and this compiler as well, but is there an easy
way around this (I tried using the unistd.h from cygwin, no dice - also
tried manually deleting from the .c file, and it gets put back in) ?

Thanks


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message