httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Thomas Greenwood <...@exel.co.uk>
Subject [users@httpd] Apache waits for 15s on some requests when there is high load
Date Tue, 05 Aug 2003 14:12:56 GMT
I am experiencing response times of 15s for a small number of requests when
apache is under high load.  I am running version 1.3.26 on Win32.  In a
little java test program I wrote to check for modified files I put in > 10
connections on as many threads together making 2250 requests as fast as they
can.  The wierd this is that > 99% of the requests come back in < 0.6s, most
< 0.1s.  With the odd request coming back at between 14.5s and 14.9s.  What
is so wierd is that ALL the requests that take > 0.7s take between 14.5s and
14.9s.  Apache does not exhibit this behaviour if there are < 10
threads/connections being used simultaneously.  This is causing a number of
problems for us.

I have attempted to alter the number of threads, and the keep alive settings
to no avail.

Thanks


************************************************************************
This email and any files transmitted with it are confidential and
intended solely for the use of the individual or entity to whom
they are addressed. Any views or opinions are solely those of
the author and do not necessarily represent those of Exel
Computer Systems plc. If you have received this email in error
please notify Customer Services on 0115 946 0101.
************************************************************************


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message