httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Denise Mangano" <Deni...@complusdata.com>
Subject [users@httpd] Cannot add mod_fastcgi
Date Wed, 27 Aug 2003 13:46:08 GMT
Hi everyone,

I compile and installed Apache 1.3.28 with DSO support, but for some
reason when I try to add mod_fastcgi I get errors.  I had some major
trouble yesterday getting Apache compiled (thanks again everyone for
your help).  At one point I tried compiling it with mod_fastcgi using
the --activate-module command, and even the --add-module command, but it
kept complaining.  I believe the problem is that apache is expecting
libfastcgi.a , it has to be generated.

I tried running the following:
	cd /usr/local/src/mod_fastcgi
	apxs -o mod_fastcgi.so -c *c

But I get the following:
	apxs:Error: Sorry, no DSO support for Apache available
	apxs:Error: under your platform.  Make sure the Apache
	apxs:Error: module mod_so is compiled into your server
	apxs:Error: binary '/usr/bin/httpd'.

I then run:
	/usr/local/apache/bin/httpd -l

And mod_so.c is in fact listed as a Compiled-in module.  So basically, I
have no means of getting the mod_fastcgi.so file generated.  I have a
third party application that is solely dependent on this module, so I
must have it installed.  Another thing worth mentioning, is that there
is no '/usr/bin/httpd' on my system.    

I checked Makefile.tmpl, and the interesting thing here is that it looks
for files in $(INCDIR)  .. But there is no where that specifies where
$(INCDIR) is.  On my system it is /usr/local/apache/include and this
directory has all the files that the Makefile needs.

This is pretty urgent, so I appreciate all your help.

Thanks.
Denise









---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message