httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Arthur Chan" <ach...@saysit.com.hk>
Subject [users@httpd] Is this an OpenSSL or httpd or Netscape problem ???
Date Mon, 04 Aug 2003 07:03:17 GMT
Hi All.
Netscape 6.2 would not "redirect" from http://my.1st.dom.com to
https://my.secure.dom.com
I have two vhosts/different root directories etc.
The 1st one listens on 80, the secure one listens on 443.
My objective : from the unsecure web site, create a link to a secure one in
index.html, using an anchor e.g.
<A HREF="http://my.secure.com.com">ClickMe</A>
In httpd.conf, I have this setup:
...
(httpd.conf)
Listen 192.168.100.1:80
Listen 443
NameVirtualHost 192.168.100.1
<VirtualHost 192.168.100.1:80>
ServerName my.1st.dom.com
...
</VirtualHost>
# as far as MSIE5 is concerned, the following 4 lines are not required for a
"redirect"
<VirtualHost 192.168.100.1:80>
ServerName my.secure.dom.com
Redirect /index.html https://my.secure.dom.com/index.html
</VirtualHost>
# as far as MSIE5 is concerned, the following lines are all that's needed.
<VirtualHost 192.168.100.1:443>
ServerName my.secure.dom.com
...
<IfModule mod_ssl.c> blabla </IfModule>
</VirtualHost>

With MSIE5, all works fine, web-site, redirect, certificate presentation and
finally content presentation.
In Netscape, the unsecure web-site presents itself again, as if it couldn't
resolve my.secure.dom.com and defaults to my.1st.dom.com .
Error log shows nothing related to this problem, jst complained that the
sessionCache is not set.

Is this a Netscape 6.2 bug ???


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message