httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alfredo Gómez Grande <ago...@agsoftware.net>
Subject Re: [users@httpd] Basic index.html Problem
Date Mon, 04 Aug 2003 09:03:05 GMT
Q= When going into a web browser, it WON'T find the index.html
automatically.  I have to specifiy, 12.209.236.180/index.html  in order to
load it up.

A= I had that same problem. I discovered it was due to not specifying the
main file extension, as our friend says below. All my "index" files were
.htm and Apache was initially configured under the DirectoryIndex directive
to access only .html files, so I had to modify this directive and to include
the .htm extension. Another thing, that I don't know is if in Linux this is
case sensitive and you have to write all the combinations.

DirectoryIndex     index.htm index.html Index.html Index.htm


----- Original Message ----- 
From: csebe@fx.ro
To: users@httpd.apache.org ; Jason Cicillian
Sent: Monday, August 04, 2003 10:52 AM
Subject: RE: [users@httpd] Basic index.html Problem


I'm not sure you already put this in your config (afaik is case sensitive
too):

DirectoryIndex index.htm index.html Index.html Index.htm

If so, posting the relevant bits from the config file would probably help.

Lian Sebe, M.Sc.
Freelance Analyst-Programmer
www.programEz.net
  -----Original Message-----
  From: Jason Cicillian [mailto:jacrebel@comcast.net]
  Sent: Monday, August 04, 2003 10:17 AM
  To: users@httpd.apache.org
  Subject: [users@httpd] Basic index.html Problem


  I have Apache installed from my Red Hat Linux 9.0 installation.  I have
tried hopelessly over and over again to get it to work right.
  What is happening is this:

  My Linux box is on a home network.  It has a DHCP address assigned by the
router...in my case 192.168.0.102
  The router is capable of using a virtual HTPP server and it takes my cable
modem WAN IP address of 12.209.236.180 and re-directs it to the Linux box.
Sweet.  Accessing 12.x.x.x.x whatever from the internet DOES go to my linux
box.

  BUT, when doing this, I get the Apache default (error index.html) that
says Apache is working right, now put your files in this direcotry /var/www
.... ok, now I configured the HTTP server in Linux and a virtual host.  I
used the Linux Box IP as the host name, server, name, everthing with a
pointer to the acutal directory containing my files.  In the search for file
types, I have index.html listed, as it IS the directory file index for this
site.

  When going into a web browser, it WON'T find the index.html automatically.
I have to specifiy, 12.209.236.180/index.html  in order to load it up.

  At work, we have an older Linux OS running ( the old /home/httpd/html
directory structure), anyway, you just type in the linux box IP address and
bam, you load the index.html.   Not so for me... WHY??? I can't find it
anywhere online.

  Thanks for you help.

  Jason

Mime
View raw message