httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Kitch, David" <dki...@ti.com>
Subject RE: [users@httpd] cgi-bin under UserDir
Date Thu, 17 Jul 2003 18:17:37 GMT
On Thu, 17 Jul 2003, Kitch, David wrote:

> On Thu, 17 Jul 2003, Kitch, David wrote:
>
> David> I'm getting "Premature end of script headers" on cgi files
under
> users'
>
> Joshua> 1. Are you running suexec?  Have you checked the suexec log?
>
> Joshua> 2. Does the script work from the command line (ie cd
> Joshua> /home/user/public_html/cgi-bin; ./script.cgi)
>
> I'm not running suexec.  The scripts work from the command line and
from
> cgi-bin inside of vhosts.

Joshua> If the cgi scripts work from a central cgi-bin, but not from
user
Joshua> directories, the problem is almost always suexec.  Try "httpd
-V", look
Joshua> for the location of SUEXEC_BIN, and see if there is an suexec
binary
Joshua> there.  If so, remove it.

Thanks for the tip Joshua.  I may have to create a separate
installation, as I'm sharing this one with other instances which may
need to use suexec (the loadmodule line for suexec is commented out of
this configuration).

David

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message