httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From awongxi <a...@accefyn.org.co>
Subject [users@httpd] newest to apache
Date Sat, 26 Jul 2003 10:21:46 GMT
Sorry this may seem as a really newbi question but... I have lost lots 
of time trying to fix this and nothing works...
I am running apache under redhat linux. the html folder with the html 
files is at /var/www/html and the cgi is at /var/www/cgi-bin
I have a simple script (perl script) that I took from the web, the perl 
path is ok, and it works when I run it on command line... well I Would 
like to see this script working via a browser so I place the script 
under /var/www/html and chmod 755 to it. well the localhost/hello.pl and 
it displays the text, the source code, ok then I rename the file as 
hello.cgi and try again and the same result...

#! /usr/bin/perl

#!/usr/local/bin/perl
# hello.pl - My first CGI program

print "Content-Type: text/html\n\n";
# Note there is a newline between 
# this header and Data

# Simple HTML code follows

print "<html> <head>\n";
print "<title>Hello, world!</title>";
print "</head>\n";
print "<body>\n";
print "<h1>Hello, world!</h1>\n";
print "</body> </html>\n";

tha is my simple script... as I sayed beore it works on command line. as cgi and as pl I have
tryed. when I check the apache log file:

it does not generate an error msg, well any way the file is being displyed as text.. so...
what am I doing wrong... 
how can I see this simple perl script working? is there anything at the http.conf file I should
check? does it have to do with the mod_perl? if so how to activate it? please please just
this simele thing.. please






---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message