httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From io...@comcast.net
Subject [users@httpd] Apache 2.0.43 rather slow in Windows
Date Wed, 30 Jul 2003 06:06:40 GMT

I've found Apache 2 relatively slow in delivering static html. I have
tested it across multiple Windows 2000 machines with similar results.
I have compared it against a Windows port of thttpd, IIS 5, and IIS 6.

I am just wondering if someone can tell me, from experience, some
showstopper patch or configuration which makes Apache perform as expected.

Right now it gets a curious 161 pages per second, while IIS gets 1061 (just
add a zero somewhere) and thttpd gets 460. I am running a fairly default
httpd.conf. These numbers are from an Athlon 700 and I expect I should get
at least double the speed from Apache. At some users' suggestion I have
performed some tweaks to httpd.conf and only made performance worse, proving
the default configuration was better.

Any suggestions? I want to see Apache perform this test well, I don't want
to be told to upgrade my hardware or similar. Just my usual disclaimer.

-Tomi


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message