httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Henning Sittler <Henn...@inscriber.com>
Subject [users@httpd] apache 2 ssl
Date Tue, 17 Jun 2003 15:02:02 GMT
Since the mod_ssl listserver isn't responding tho my subscribe right now,
I'll ask this here.

I'm running Apache 2 and mod_ssl on Redhat 9 installed using apt-get.  

Multiple vhosts are running fine for sometime now, but since I've moved up
to Apache from 1.3, I can't get mod_ssl to work.  When I stop and start
apache, the ssl.conf file is read and it prompts for the ssl key passphrase.
It accepts the correct passphrase without complaint or error and reports
[OK].  I believe this confirms that apache and mod_ssl are properly using
the correct key and cert files.

Looking in the logs/ssl_error_log shows absolutely nothing, as do
ssl_access_log and ssl_request_log (as expected). BUT browsing to port 443
in IE shows only a 'Page cannot be displayed' message, AND still absolutely
no errors or info in any of the ssl_*_log files.  Even the main apache
error_log shows no related messages.

I have set LogLevel to debug only until I get the ssl vhost working.  I have
checked my iptables to confirm port 443 is open.

I have also tried the following:
----
# openssl s_client -connect localhost:443 -state -debug
CONNECTED(00000003)
SSL_connect:before/connect initialization
write to 080AED38 [080AFD08] (142 bytes => 142 (0x8E))
0000 - 80 8c 01 03 01 00 63 00-00 00 20 00 00 39 00 00   ......c... ..9..
0010 - 38 00 00 35 00 00 16 00-00 13 00 00 0a 07 00 c0   8..5............
0020 - 00 00 33 00 00 32 00 00-2f 03 00 80 00 00 66 00   ..3..2../.....f.
0030 - 00 05 00 00 04 01 00 80-08 00 80 00 00 63 00 00   .............c..
0040 - 62 00 00 61 00 00 15 00-00 12 00 00 09 06 00 40   b..a...........@
0050 - 00 00 65 00 00 64 00 00-60 00 00 14 00 00 11 00   ..e..d..`.......
0060 - 00 08 00 00 06 04 00 80-00 00 03 02 00 80 35 63   ..............5c
0070 - 73 ba 07 57 0e 17 68 56-ea be 96 b0 56 77 03 05   s..W..hV....Vw..
0080 - d2 06 d1 d7 d3 f7 ab e6-a2 95 72 6e 2e 89         ..........rn..
SSL_connect:SSLv2/v3 write client hello A
read from 080AED38 [080B5268] (7 bytes => 0 (0x0))
3419:error:140790E5:SSL routines:SSL23_WRITE:ssl handshake
failure:s23_lib.c:226:
----

What else can I check for?  What could I be missing?  Thanks for any help or
suggestions.


Henning 


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message