httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Kaplan, Andrew H." <AHKAP...@PARTNERS.ORG>
Subject [users@httpd] htaccess authentication not working
Date Fri, 06 Jun 2003 18:21:45 GMT
I am trying to set up authentication to the webserver using the .htaccess
file. Here are the steps that I have completed:

		1. Modified the httpd.conf file where AccessFileName
.htaccess
		2. Changed the Directory setting as follows"
					<Directory />
						Options Follow SymLinks
						AllowOverride AuthConfig
					</Directory>
		3. Restarted the Apache server
		4. Created an .htaccess file in /var/www/Documents with the
following syntax:
				AuthName	"Radiation Oncology"
				AuthType	Basic
				AuthUserFile
/usr/local/apache/conf/.users
				Require 	valid-user
		5. Created a .users file:
			/usr/local/apache/bin/htpasswd -c
/usr/local/apache/conf/.users
		6. Restarted Apache for good measure.

I am not getting getting prompted for a password at the welcome screen. The
document root directory is /var/www/Documents.
What am I missing here?


		

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message