httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ezra <e...@acedsl.com>
Subject Re: [users@httpd] Error Starting Up apache with SSL
Date Tue, 10 Jun 2003 05:40:37 GMT
Hello Julio:
		 You should really upgrade.  Apache is up to 2.0.46.  Also, the option 
--enable-ssl is incomplete. Where is openssl installed. You have to 
specify this location in order for ssl to work inside of Apache.

Example:
	--enable-ssl
         --with-ssl=/usr/src/openssl

Julio César Mejia Vergara wrote:
> Hello,
> 
> I need to run Apache 2.0.39 with SSL.
> http run ok but https generates an error on startup.
> I compiles allright but when i try to start up apache with ssl i get 
> this error:
> 
> # ./apachectl startssl
> [Mon Jun 09 12:21:13 2003] [crit] [Mon Jun 09 12:21:13 2003] file 
> vhost.c, line 232, assertion "rv == APR_SUCCESS" failed
> Abort - core dumped
> #
> 
> I checked the file vhost.c
> 
> find / -name vhost.c -print
> /export/home/jume/httpd-2.0.39/server/vhost.c
> 
> and this is the lines that fales:
> 
> else if (strcasecmp(host, "_default_") == 0
>         || strcmp(host, "255.255.255.255") == 0) {
>         rv = apr_sockaddr_info_get(&my_addr, "255.255.255.255",APR_INET, 
> port, 0, p);
>         ap_assert(rv == APR_SUCCESS); /* must be bug or out of storage*/
> 
> I'm tring to make it run on Solaris 8 (SPARC Ultra 5) i have instaled 
> this software and all recent Solaris 8 Patches:
> - ANDIrand-0.7
> - autoconf 2.5
> - automake 1.7.2
> - expect 5.38
> - gcc 3.2.2
> - gd 1.8.3
> - j2sdk 1.4.1_01
> - jakarta ant 1.5.1
> - libgcj 2.95.1
> - libtool 1.4
> - m4 1.4
> - make 3.80
> - memconf 1.52
> - ntop 1.3.1
> - openssl 0.9.6g
> - perl 5.8.0
> - tar 1..13.19
> - tcl 8.4.1
> - tk 8.4.1
> - top 3.5
> 
> Mi PATH's:
> 
> PATH=$PATH:/usr/local/bin:/usr/ccs/bin:usr/local/ssl/bin:/opt/jakarta-ant-1.5.1/bin:usr/local/apache/bin:usr/local/apache/lib:/opt/jakarta-tomcat-3.2.4/bin:.

> 
> LD_LIBRARY_PATH=/usr/local/lib:/lib:/usr/lib:/usr/local/ssl/lib:/opt/jakarta-ant-1.5.1/lib:/usr/local/apache/lib

> 
> MANPATH=/usr/local/man:/usr/local/apache/man:/usr/local/ssl/man:/opt/jakarta-ant-1.5.1/man:$MANAPATH

> 
> JAVA_HOME=/usr/j2se
> TOMCAT_HOME=/opt/jakarta-tomcat-3.2.4
> AC_MACRODIR=/usr/local/share/autoconf
> CLASSPATH=/usr/local/lib/tools.jar:/usr/java/lib:/opt/jakarta-tomcat-3.2.4/lib:/opt/jakarta-tomcat-3.2.4/lib/servlet.jar:/opt/jakarta-tomcat-3.2.4/lib/servlet_2_2.jar:/opt/jdbc_db2/lib/jt400.jar:/opt/jdbc_ifmx/lib/ifxjdbc.jar:/opt/jakarta-tomcat-3.2.4/lib/kcServlet.jar:/usr/java/src.jar:/usr/java/lib/dt.jar

> 
> CATALINA_HOME=/opt/jakarta-tomcat-3.2.4
> 
> export PATH LD_LIBRARY_PATH JAVA_HOME CATALINA_HOME TOMCAT_HOME 
> CLASSPATH AC_MACRODIR
> 
> And i compiled like this:
> 
> #cd /opt/temp
> #gunzip httpd-2.0.39.tar.gz
> #tar -xvf httpd-.2.0.39.tar
> #cd httpd-2.0.39
> #./configure –prefix=/usr/local/apache –enable-so –enable-info 
> –enable-ssl –enable-modules-all
> #make
> #make install
> 
> Any Ideas and what going wrong.
> 
> Thanks
> Julio
> jume2k@yahoo.com
> 
> 
> 
> 
> 
> 
> ---------------------------------------------------------------------
> The official User-To-User support forum of the Apache HTTP Server Project.
> See <URL:http://httpd.apache.org/userslist.html> for more info.
> To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
>   "   from the digest: users-digest-unsubscribe@httpd.apache.org
> For additional commands, e-mail: users-help@httpd.apache.org
> 
> 



---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message