httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Laus, Ryan J." <laus...@cmich.edu>
Subject RE: [users@httpd] Page Will Not Display After Modifications
Date Thu, 19 Jun 2003 12:23:27 GMT
Robert,

(Also pre-coffee) As far as I can tell from the packet trace, as soon as
the client tries to request the web page, it is immeadiatly sent back a
FIN ACK packet.  There is no precluding FIN packet (without the ACK),
which closes the session without receiving any sort of data.

This only happens to the page that has been modified, all other pages
work fine.  Here is what is showing up in the access log when a client
will try to go to the page when it is giving the "page cannot be
displayed error"

141.xxx.xxx.xxx - - [17/Jun/2003:14:58:12 -0400] "GET
/temp/parkhours.htm HTTP/1.1
" 200 14348
141.xxx.xxx.xxx - - [17/Jun/2003:14:58:12 -0400] "GET
/temp/parkhours.htm HTTP/1.1
" 200 14348 "-" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)"
141.xxx.xxx.xxx - - [17/Jun/2003:14:58:13 -0400] "GET
/temp/parkhours.htm HTTP/1.1
" 200 14348
141.xxx.xxx.xxx - - [17/Jun/2003:14:58:13 -0400] "GET
/temp/parkhours.htm HTTP/1.1
" 200 14348 "-" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)"
141.xxx.xxx.xxx - - [17/Jun/2003:14:58:41 -0400] "GET
/temp/parkhours.htm HTTP/1.1
" 200 14348
141.xxx.xxx.xxx - - [17/Jun/2003:14:58:41 -0400] "GET
/temp/parkhours.htm HTTP/1.1
" 200 14348 "-" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)"
141.xxx.xxx.xxx - - [17/Jun/2003:14:58:43 -0400] "GET
/temp/parkhours.htm HTTP/1.1
" 200 14348
141.xxx.xxx.xxx - - [17/Jun/2003:14:58:43 -0400] "GET
/temp/parkhours.htm HTTP/1.1
" 200 14348 "-" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)"
141.xxx.xxx.xxx - - [17/Jun/2003:14:59:28 -0400] "GET
/temp/parkhours.htm HTTP/1.1
" 200 14348

There is nothing in the error_log.  I agree in that it seems like it is
something with the OS.  So far I have only found one other person who is
having the same problem and he is using WebLogic and not Apache.  Any
more ideas?

Regards,
Ryan Laus


-----Original Message-----
From: Robert Andersson [mailto:robert@profundis.nu] 
Sent: Thursday, June 19, 2003 2:02 AM
To: users@httpd.apache.org
Subject: Re: [users@httpd] Page Will Not Display After Modifications


Laus, Ryan J wrote:
> I then did some packet captures to see what was actually happening 
> between the web server and the client.  After the changes have been 
> made to the page, the client will try to GET the web page.  The next 
> packet back from the server is a FIN ACK packet, which starts the TCP 
> teardown sequence, which is why the "Page cannot be displayed" comes 
> up.

You mean that the connection is simply killed as soon as the request is
made?

[pre-coffee]
My TCP skills are a bit rusty now, but if I remember correctly, FIN ACK
is what one party sends to acknowledge the closing initiated by the
other party which would indicate that it is the client that is closing
on the server. It could, however, be the other way around, as you
suggested. [/pre-coffee]

> This goes on for around 4-5 minutes.  Then, all of the sudden, the 
> HTTP GET packet works and the server acknowledges back with a 
> "HTTP/1.1 200 OK" and the page can then be viewed.

Is this only the case when requesting the file that has previously been
modified, or does it apply to any file? And there is nothing in the
access or error log about it?

I'd guess that this is an OS issue, and I'd suggest you run a strace, so
you can see where it goes down.

Regards,
Robert Andersson.



---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message