httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Zac Stevens <...@cryptocracy.com>
Subject Re: [users@httpd] Suexec and apache 2.0.46 - scripts not run with suexec
Date Thu, 19 Jun 2003 09:56:36 GMT
On Thu, Jun 19, 2003 at 12:25:04PM +0300, Artur Signell wrote:
> Suexec is working properly and apache is built with  
> --with-suexec-userdir=cgi-bin. In fact if I skip the rewrite rule and
> add a symlink: /home/username/html/cgi-bin -> /home/username/cgi-bin 
> the script is executed with suexec as the user. But this method is not 
> possible to use in my case.

Sorry, I see what you're saying now - and it's worth noting that this is
really a problem with mod_rewrite, not suexec.  You may want to try adding
the 'PT' option to your RewriteRule, as it seems to be applicable to your
case.  

Failing that, turn up RewriteLogLevel (and define a RewriteLog if you don't 
have one) to get a detailed breakdown of the steps taken in processing the 
rewrite - this can often help pinpoint where things are going wrong.



Zac

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message