httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Felix Seeger <see...@sitewaerts.de>
Subject Re: [users@httpd] Performance problems with Apache2 under Solaris 9
Date Tue, 17 Jun 2003 16:08:25 GMT
Am Dienstag, 17. Juni 2003 18:00 schrieb Joshua Slive:
> On Tue, 17 Jun 2003, Felix Seeger wrote:
> > I have compiled Apache httpd 2.0.46 under Solaris 9 on Netra T1 200
> > (UltraSPARC-IIe) with gcc 2.95.3. Latest patch cluster from sun is
> > installed.
> >
> > The server works well, but when I download a zip file (for testing I use
> > a 500MB one) cpu usage jumps to 100%.
> > I only get between 300 and 800kb/s on my local net (100baseTx-FD)
> >
> > On the sun the CPU states from top look like this:
> > CPU states:  0.0% idle,  0.0% user, 97.7% kernel,  2.3% iowait,  0.0%
> > swap
>
> Obviously some sort of kernel issue, not directly to do with the apache
> source code.  A couple suggestions:
>
> Try using the EnableSendfile directive to disable the use of the
> sendfile() system call and see if that helps.
Ah, big thanks, now it works with 5-6MB/s and 20% kernel load.

> Try strace on an affected httpd to see what it is doing.
>
> Joshua.

Thanks again !
have fun
Felix 


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message