httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Klavs Klavsen ...@vsen.dk>
Subject RE: [users@httpd] perl-cgi won't work with apache2
Date Sat, 28 Jun 2003 13:41:22 GMT
On l
> Klavs,
> 
> There is one thing you didn't mention in your problem description:
> - where exactly is the script your calling (full path to it).
> 
/usr/local/sql-ledger/login.pl - path via browser
sql-ledger.domain.dk/login.pl.

> As for debugging, I'd start to simplify configuration until it works and
> then complicate it back.
> 
> Try for example a simple perl "Hello world" script, in a simple dir (created
> specially for testing), in the main apache server config, no aliases, no
> nothing, only the AddHandler, as plain as possible.
> 
Tried this script:

#!/usr/bin/perl
#
print "Content-Type: text/plain\n\n";
print "<html><body>Hello World</body></html>";

It works as expected in shell - I also tried putting it under another
vhost - no change, still just shows the source of the script.

what info can I contribute with? What can/should I test? 
The server is running php scripts just fine in the directories I tried
this in, and it is running my own site too.

-- 
Regards,
Klavs Klavsen, GSEC - kl@vsen.dk - http://www.vsen.dk
PGP: 7E063C62/2873 188C 968E 600D D8F8  B8DA 3D3A 0B79 7E06 3C62
See my new hosting service at http://hosting.EnableIT.dk

Working with Unix is like wrestling a worthy opponent. 
Working with windows is like attacking a small whining child 
who is carrying a .38.				

Mime
View raw message