httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Dean A. Mills" <dami...@charter.net>
Subject [users@httpd] Proxy/Authen/Smb help
Date Mon, 09 Jun 2003 01:20:54 GMT
Im using

apache 1.3.27
mod_perl-1.27

Im trying to log intranet usage, I have the following in httdp.conf (proxy 
request are on)

<Directory />
AuthName "Testing authen"
AuthType Basic
PerlAuthenHandler Apache::AuthenSmb
PerlSetVar myPDC pdc.mynet
PerlSetVar myBDC bdc.mynet
PerlSetVar myDOMAIN mine
require valid-user
</Directory>

I have a basic proxy.pac in htdocs, IE is configured with config script 
pointing to http://myapache.mynet/proxy.pac
My problem is this

When I make a request to the apache server, for example http://mypache.net, 
Im prompted for id/pw, it will validate against my pdc, works great. Also 
if I dont put a id/pw in, it will show page "Authorization required" as I 
would think it would

The problem is when I make a request to something other than the apache 
proxy server (ie. msn.com, cnn.com, etc), I DO get prompted for id/pw just 
like hitting the apache proxy server, works great when I put in an valid 
id/pw. BUT if I keep hitting cancel or use a blank or id/invalid pw, I keep 
getting the authentitication dialog box along with the web page (ie. 
msn.com, cnn.com, etc).

Why does it work for invalid id/pw for proxy server, but not the external 
sites? Im trying to track internet usage. Ive tried modifyinf AuthenSmb.pm 
w/o any luck, seems like Im not redirecting the output correctly

Anyone ran into this?




---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message