httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mauricio Lara \(NOVA\)" <ml...@novadevices.com>
Subject [users@httpd] Proxy logs
Date Mon, 23 Jun 2003 23:19:34 GMT
Dear Friends


I tried configure mod_proxy all work fine but I have a big problem with the logs files.

My network 


wan ip/lan ip 192.168.1.222               ip lan 192.168.1.32

Apache/2.0.40                                    Apache /2.0.40
---------------------                                   ---------------------
|                    | ___________________|                     |
|___________ |                                  |---------------------|
mod_proxy


I wanna maintain the original client ip in the logs because when I open my log file in my
lan server the only ip is 192.168.1.222(proxy httpd server)

In my first server (222) the httpd.conf is normal and in the virtual section I have this

<VirtualHost *>
    ServerName www.interna.com
    ProxyPass / http://192.168.1.32/
    ProxyPassReverse / http://192.168.1.32/
</VirtualHost>

I tried with but not work
    ProxyPreserveHost On
    RPAFenable On
    RPAFsethostname On
    RPAFproxy_ips 127.0.0.1 192.168.1.222 192.168.1.221 192.168.1.32
    ProxyRequests On
    ProxyVia Off

My client is other pc in the lan not 192.168.1.222 for example 192.168.1.11

But my log file always is:

192.168.1.222 - - [23/Jun/2003:14:16:58 -0500] "GET /apache_pb.gif HTTP/1.1" 200 2326
192.168.1.222 - - [23/Jun/2003:14:16:58 -0500] "GET / HTTP/1.1" 200 1852
192.168.1.222 - - [23/Jun/2003:14:16:58 -0500] "GET /apache_pb.gif HTTP/1.1" 200 2326
192.168.1.222 - - [23/Jun/2003:14:16:58 -0500] "GET / HTTP/1.1" 200 1852
192.168.1.222 - - [23/Jun/2003:14:16:58 -0500] "GET /apache_pb.gif HTTP/1.1" 200 2326
192.168.1.222 - - [23/Jun/2003:17:17:14 -0500] "GET / HTTP/1.1" 200 1852
192.168.1.222 - - [23/Jun/2003:17:17:14 -0500] "GET /apache_pb.gif HTTP/1.1" 304 -
192.168.1.222 - - [23/Jun/2003:17:17:16 -0500] "GET / HTTP/1.1" 200 1852
192.168.1.222 - - [23/Jun/2003:17:17:16 -0500] "GET /apache_pb.gif HTTP/1.1" 304 -
192.168.1.222 - - [23/Jun/2003:17:17:18 -0500] "GET /manual/index.html HTTP/1.1" 200 5740
192.168.1.222 - - [23/Jun/2003:17:17:19 -0500] "GET /manual/images/pixel.gif HTTP/1.1" 304
-
192.168.1.222 - - [23/Jun/2003:17:17:19 -0500] "GET /manual/images/apache_header.gif HTTP/1.1"
304 -
192.168.1.222 - - [23/Jun/2003:17:17:21 -0500] "GET /manual/mod/index-bytype.html HTTP/1.1"
200 6390
192.168.1.222 - - [23/Jun/2003:17:17:22 -0500] "GET /manual/images/index.gif HTTP/1.1" 200
1540
192.168.1.222 - - [23/Jun/2003:17:17:22 -0500] "GET /manual/images/sub.gif HTTP/1.1" 200 6083
192.168.1.222 - - [23/Jun/2003:17:17:22 -0500] "GET /manual/images/home.gif HTTP/1.1" 200
1465


Please help me 

Thanks

Mauricio

Mime
View raw message