httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "michael portmann" <mipo...@gmx.ch>
Subject Re: [users@httpd] mod_rewrite and mod_ssl
Date Mon, 23 Jun 2003 12:36:03 GMT
Hi

I installed the packages with apache 1.3.27 and mod_ssl 2.8.14 and it works
fine, no problem to access ssl-variables with mod_rewrite....
Both systems run Mandrake 9.1, so there should be no difference. Could it be
that I missed sth to configure on my apache 2.0.45 (MM is not installed in
Apache2), or does one of the included mod_ssl or rewrite package is an quite
older version that this one of apache 1.3.27???

Thanks for your inputs

Eudgster




----- Original Message ----- 
From: "michael portmann" <miporti@gmx.ch>
To: <users@httpd.apache.org>
Sent: Monday, June 23, 2003 9:47 AM
Subject: [users@httpd] mod_rewrite and mod_ssl


> Hi
>
> I have problems to get access to SSL Environment Variables. If I
> want to redirect in order of the protocol version (TLSv1, SSLv3,
> SSLv2), the received input string is always empty.
>
> //conf file
> SSLOptions +StdEnvVars
>
> RewriteCond %{SSL_PROTOCOL} ^SSL*
> RewriteRule ^/$     /dir1/index.html
>
> //Error Log
> 10.0.0.7 - - [04/Jun/2003:16:54:10 --0400]
> [xxxx/sid#814b3f8][rid#81a1328/initial] (4) RewriteCond:
> input='' pattern='^SSL*' => not-matched
>
> input is always empty, but in the CustomLog-File from Apache has
> access to this
> env. variable. There I see the different protocol versions.
>
> It should be possible to get access on them, because in
>
http://groups.google.ch/groups?hl=de&lr=&ie=UTF-8&oe=UTF-8&threadm=78ac2v%2451f%241%40nnrp1.dejanews.com&rnum=1&prev=/groups%3Fq%3Dmod_rewrite%252Bssl%252Bvariables%26hl%3Dde%26lr%3D%26ie%3DUTF-8%26oe%3DUTF-8%26selm%3D78ac2v%252451f%25241%2540nnrp1.dejanews.com%26rnum%3D1
> wrote Ralf Engelschall in context to mod_rewrite and mod_ssl: "And
> since mod_ssl 2.1.8 mod_rewrite can access all variables from mod_ssl."
>
> I am running apache 2.0.45 on mandrake 9.1, could it be that there is an
> older version of mod_ssl in apache2.x, which does not support this?
>
> Any help would be very appreciated.
>
> Regards, Eudgster
>
>
>
> ---------------------------------------------------------------------
> The official User-To-User support forum of the Apache HTTP Server Project.
> See <URL:http://httpd.apache.org/userslist.html> for more info.
> To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
>    "   from the digest: users-digest-unsubscribe@httpd.apache.org
> For additional commands, e-mail: users-help@httpd.apache.org
>
>



---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message