httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jeremy Madea <J.Ma...@mdl.com>
Subject RE: [users@httpd] Coult not bind to port 80
Date Thu, 08 May 2003 19:04:35 GMT
On Thursday, May 08, 2003 9:45 PM, Olga Lucia Cardoso wrote: 

> I got the following error:
> 
> Address already in use: could not bind to port 80.
> 
> I can not find who is using the port; although if I change 
> the port number, apache starts, I need to setup with the right port.

You probably have another httpd listening on 80. Maybe you started it before
and failed to shut it down. Is there a httpd.pid file somewhere (probably
your logs directory?)

You might need to poke around a bit. The commands netstat and ps are your
friends. Try (as root): 

    netstat -pa | grep http 


> I am not using the apache included on RedHat, I installed version 1.3 
> downloaded from apache.

If you previously installed the RedHat default, it is likely that it is
starting on boot.


-j

--
Jeremy Madea
"My two cents aren't worth a dime." 

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message