httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From <...@ulysium.net>
Subject [users@httpd] mod_cgi mod_cgid & suexec
Date Sat, 17 May 2003 19:50:32 GMT
I've been posting about the mod_cgi and mod_cgid today, nobody suggested
anything yet, but I'm testing a few things...

At first, I had mistakenly used both cgi and cgid, and got no logging as a
result.
Then I recompiled without cgi and only with cgid as static module. That
brought back cgi logging but the scripts don't work because the cgi daemon
isn't running.
I also got rarely any logging from suexec when both cgi modules were loaded,
but got no suexec logging at all with cgid.

Now I put cgi back in and removed cgid, the cgi logging does work, as well
as suexec's logging, and the scripts do run properly, but since I'm running
the worker mpm, I was under the impression this wasn't a good choice
whenever using a multi-threaded apache and that using cgid is recommended
instead, but it doesn't work, so cgi it is...

The big question is, is there a way to make this cgid daemon to run, and
will it work properly with suexec???

I'm going to continue using mod_cgi for now because it works, but I think
mod_cgid should be the better choice under the worker mpm. Is that correct?

-- 
Didier Godefroy
mailto:dg@ulysium.net


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message