httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From <...@ulysium.net>
Subject [users@httpd] small Suexec problem
Date Thu, 08 May 2003 22:50:07 GMT
Hello all,
I've been lurking on the list and didn't find any hints to help me with my
little suexec problem.
the system is tru64 unix, apache 2.0.45
I was able to run small test cgi scripts without suexec enabled
(disabling the suexecusergroup directive)
but with suexec re-enabled, it seems it's not even getting close to the
script itself for execution.
What I get is an error in the suexec log that says:

cannot get current working directory

that's after it found the correct uid and gid specified by the
suexecusergroup, which do match the system's for that user.

I tried something a little odd to test a hunch I had, but it didn't reveal
what I thought it would: I sued to the httpd user and moved into the apache
root folder, then tried to su from that location to the user which is meant
to execute the scripts, and it worked fine, I could even do it from the bin
folder located in the apache root folder, and I could move to the location
of the script as the script's user from either location inside apache's
root.
At least I thought I'd get a similar error to the suexec one if I tried to
do something a little similar manually, by changing from the httpd user to
the non-privileged one supposed to run the script. If it was a permission
issue, I thought this would've been revealed that way...

I have no symlinks in the path to the cgis and apache's root, nor to the
document root in the user's account, I have the full path defined in the
config, avoiding any symlinks that could get in the way.

Is there anything else I need to look for?

-- 
Didier Godefroy
mailto:dg@ulysium.net


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message