httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kyle <k...@ccidomain.com>
Subject [users@httpd] Require valid-user on alias directory problem
Date Fri, 16 May 2003 12:56:07 GMT
I have a domain that uses .htaccess to require a password to gain access 
to the entire web site.

Recently I decided to allow access to the RedHat installed module 
documentation by adding this to my virtual host definition:

    Alias /doc/ /usr/share/doc/
    <Directory /doc>
       order deny,allow
       Allow from all
       Require valid-user
       Options Indexes FollowSymLinks
    </Directory>

When I log into the web site I give a name and password to gain access. 
  I can surf to any page on the web site except for the ones in the 
/doc/ directory.  Those all give me a 403 Forbidden message (error).

I also tried replacing the <Directory> directive with <Location>, but 
had similar problems.

Can anybody suggest how I might modify the above snippet to require a 
valid user that has already logged in?

I am using Apache 1.3.27 on RedHat 7.3.  Thanks in advance.

-Kyle


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message