httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From pritesh sharma <prit_sha...@yahoo.com>
Subject [users@httpd] installing apache 2.0 on solaris 2.8
Date Sun, 04 May 2003 03:27:30 GMT
Hi,
  I am Pritesh.I am a student and am using apache as a
server benchmark for studying a memory allocator.I am
unable to install Apache 2.0 though.I would be very
grateful if someone could help me out.

The platform is solaris 2.8.The gcc version is 3.0.3.
Additional information which might be useful is that I
am using the --enable-pool-debug=yes flag(I am doing
this so that Apache 2.0 is forced to use the system
malloc and free).

The make process gives the following error:
PTHREAD_MUTEX_ROBUST_NP' undeclared (first use in this
function)
`PTHREAD_PRIO_INHERIT' undeclared (first use in this
function)

 I am including the portion of the "make" process
which gives the error:

  Making all in locks/unix
/bin/bash
/projects/emery/prsharma/httpd-2.0.45/srclib/apr/libtool
--silent --mode=compile gcc -g -O2 -pthreads  
-DHAVE_CONFIG_H -DSOLARIS2=8
-D_POSIX_PTHREAD_SEMANTICS -D_REENTRANT
-DAPR_POOL_DEBUG=1 .....

I would be really grateful if someone could help me
soon.
Regards
Pritesh

I am also including the output of gcc -v just in
case..

../gcc/configure --prefix=/lusr/gnu --enable-shared
--enable-java-gc=boehm --enable-threads=posix
--with-as=/lusr/gnu/bin/as --with-ld=/lusr/gnu/bin/ld
Thread model: posix
gcc version 3.0.3



__________________________________
Do you Yahoo!?
The New Yahoo! Search - Faster. Easier. Bingo.
http://search.yahoo.com

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message