httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Travis Haddock <travis.hadd...@comcast.net>
Subject Re: [users@httpd] desperate please help
Date Fri, 09 May 2003 14:02:44 GMT
Hmmmm... doesn't Netgear have an FAQ about setting up web serving 
through its routers?

I've got a Netgear and it seems like you need to check your IP setup 
and enable Port Forwarding. 

When you setup the router, it takes the IP address from your ISP 
(24.105.197.156?) and then does DHCP serving for the computers 
attached to the hub, taking 192.168.0.1 for itself and assigning 
192.168.0.02, .03, .04 ... to the rest.  The router then does NAT'ing 
between the external IP and the assigned internal IPs. 

When you go to http://192.168.0.1, you are going to the router's 
admin webpage.  From there you can setup fixed or DHCP serving 
under "LAN IP Settings".  
 
So, you need to verify that your web server is no longer set to the 
external IP but to one of the assigned internal IPs.  

Then verify that Apache is configured to listen on this internal IP.  

Then, on the router's admin page, go to "Port Forwarding" and 
configure the router to forward the "HTTP" service to 192.168.0.#.  




----- Original Message -----
From: Luis Moreira <lamoreira@bes.pt>
Date: Friday, May 9, 2003 8:43 am
Subject: Re: [users@httpd] desperate please help

> Hi
> 
>    Just my ten cents worth...
> 
>    When you activate ICS in Microsoft, the computer that has the 
> Internetaccess is always given 192.168.0.1, at activation time, on 
> the LAN card.
>    If you want to have ICS without all these problems, I suppose 
> you could
> get a second card, and have a "inner" LAN working .
> 
>    I have this solution at home : ADSL with a USB modem, then an 
> ethernetcard to share that connection to the inside of my humble 
home.
>    Obviously you need a proxy. I for one use a (pretty good) 
> freeware,ANALOGX.
> 
>    Hope this helps.
> 
> Luis
> 
> ----- Original Message -----
> From: "Boyle Owen" <Owen.Boyle@swx.com>
> To: <users@httpd.apache.org>
> Sent: Friday, May 09, 2003 1:12 PM
> Subject: RE: [users@httpd] desperate please help
> 
> 
> >-----Original Message-----
> >From: CJ [cherryo@localnet.com]
> >
> >Thank you for responding...yes it did come with a manual, it
> >tells me to
> >open my browser and type in the address http://192.168.0.1 and it 
> will>take me to the page to setup up my original conf to work with 
the
> >connection, but when I type the page in it says the page cant be 
> found.>It doesn't say another way to conf it.
> 
> I think what this means is that the hub has a mini-webserver built 
> into it
> which is listening to address 192.168.0.1. The idea is that you 
> connect to
> the hub, surf to that address and you'll find a browser based 
> configurationinterface.
> 
> I imagine your server is still assigned your original address
> (24.105.197.156)? If so, you have to assign it to the 192.168.0.0 
> network(at the moment, your server doesn't know how to contact a 
> 192.168.0.0network address). In Unix, this is done using the 
> routing table
> (netstat -rn). I've no idea how you do it on windows - I assume 
> you do?
> 
> Try opening a command prompt window and pinging 192.168.0.1 - what 
> happens?
> BTW, did you understand the instructions I posted earlier - did 
> any of that
> make sense?
> 
> Rgds,
> Owen Boyle
> Disclaimer: Any disclaimer attached to this message may be ignored.
> >
> >
> >-----Original Message-----
> >From: Boyle Owen [Owen.Boyle@swx.com]
> >Sent: Friday, May 09, 2003 7:11 AM
> >To: users@httpd.apache.org
> >Subject: RE: [users@httpd] desperate please help
> >
> >>-----Original Message-----
> >>From: CJ [cherryo@localnet.com]
> >>
> >>I just installed a netgear cable/dsl wireless router to share 
> internet>>access with another comp. I have apache 2.0.44 installed 
and
> >>running win
> >>xp. Before I installed the hub the internet was able to connect 
> to my
> >>domain name cherrysplace.com fine. And my ip address was
> >24.105.197.156
> >>Now after installing the hub nobody can access my website and it is
> >>giving me a different ip which is 192.168.0.1. I am using no-ip 
> as a
> >>redirect for my domain name to use with apache and with the hub
> >>installed it is telling me that my ip is 204.xx something or
> >another. I
> >>had to unplug the hub to get my old ip back and my site works fine
> >>again. Please help, I cannot figure how to configure this with 
> the hub
> >>installed.
> >
> >In the original setup, you had your server connected directly to the
> >internet and with IP = 24.105.197.156, is this correct?
> >
> >Now you have put a hub between your server and the internet, is this
> >correct?
> >
> >Then, assuming your hub can do network address translation,
> >you have to:
> >
> >- assign the external IP address (24.105.197.156) to the
> >outside port of
> >the hub
> >- configure it to route incoming packets addressed to 
> 24.105.197.156 to
> >192.168.0.1 on the internal port
> >- connect the internal port to the apache server
> >- configure the server IP to be 192.168.0.1 (see ipconfig)
> >- configure apache to listen to 192.168.0.1
> >
> >As to how you actually configure the hub, I've no idea...
> >Didn't it come
> >with a manual?
> >
> >Rgds,
> >Owen Boyle
> >Disclaimer: Any disclaimer attached to this message may be ignored.
> >
> >
> >
> >
> >
> >
> >
> >>I am not having problems with the netgear at all, when it was
> >hooked to
> >>both comps, we can both access the internet, I am only having 
> problems>>with configureing my ip.
> >>thanks
> >>
> >>
> >>
> >>-----------------------------------------------------------------
> ----
> >>The official User-To-User support forum of the Apache HTTP
> >>Server Project.
> >>See <URL:" target="l">http://httpd.apache.org/userslist.html> 
> for more info.
> >>To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
> >>   "   from the digest: users-digest-unsubscribe@httpd.apache.org
> >>For additional commands, e-mail: users-help@httpd.apache.org
> >>
> >>
> >
> >This message is for the named person's use only. It may contain
> >confidential, proprietary or legally privileged information. No
> >confidentiality or privilege is waived or lost by any 
> mistransmission.>If you receive this message in error, please 
> notify the sender urgently
> >and then immediately delete the message and any copies of it from 
> your>system. Please also immediately destroy any hardcopies of the 
> message.>You must not, directly or indirectly, use, disclose, 
> distribute, print,
> >or copy any part of this message if you are not the intended 
> recipient.>The sender's company reserves the right to monitor all 
> e-mail
> >communications through their networks. Any views expressed in this
> >message are those of the individual sender, except where the message
> >states otherwise and the sender is authorised to state them to be 
the
> >views of the sender's company.
> >
> >
> >
> >------------------------------------------------------------------
> ---
> >The official User-To-User support forum of the Apache HTTP Server
> >Project.
> >See <URL:" target="l">http://httpd.apache.org/userslist.html> for 
> more info.
> >To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
> >   "   from the digest: users-digest-unsubscribe@httpd.apache.org
> >For additional commands, e-mail: users-help@httpd.apache.org
> >
> >
> >
> >
> >------------------------------------------------------------------
> ---
> >The official User-To-User support forum of the Apache HTTP
> >Server Project.
> >See <URL:" target="l">http://httpd.apache.org/userslist.html> for 
> more info.
> >To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
> >   "   from the digest: users-digest-unsubscribe@httpd.apache.org
> >For additional commands, e-mail: users-help@httpd.apache.org
> >
> >
> 
> -------------------------------------------------------------------
> --
> The official User-To-User support forum of the Apache HTTP Server 
> Project.See <URL:" 
> target="l">http://httpd.apache.org/userslist.html> for more info.
> To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
>   "   from the digest: users-digest-unsubscribe@httpd.apache.org
> For additional commands, e-mail: users-help@httpd.apache.org
> 
> 
> 
> -------------------------------------------------------------------
> --
> The official User-To-User support forum of the Apache HTTP Server 
> Project.See <URL:" 
> target="l">http://httpd.apache.org/userslist.html> for more info.
> To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
>   "   from the digest: users-digest-unsubscribe@httpd.apache.org
> For additional commands, e-mail: users-help@httpd.apache.org
> 
> 


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message