httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mathias Alt <al...@gmx.de>
Subject Re: [users@httpd] strange behavior of mod_auth_ldap
Date Tue, 20 May 2003 14:17:02 GMT
> Mathias Alt wrote:
> > I want to control the access of browsing users via authorization
> > against a LDAP-Server on Novell NetWare6 using the Apache 2.0.45
> > binary release on a Windows 2000 machine.
> > 
> > It is only possible that the very first user can acces the site. All
> > the next don't get access. And if the first user types a wrong name
> > or password, nobody will be able to get on the site.
> > 
> > When I restart the server I can get access as a different user, but
> > then the same story.
> 
> This looks like the bug I reported a while ago, though in my case it was 
> against an MS Active Directory server: authentication works if the 
> credentials are correct, but if they are wrong, all subsequent tries 
> fail, whether correct or not.
>  From what I understand, the LDAP module is buggy, and caches failed 
> connections against LDAP servers which do not allow anonymous bind.
> 
> Complete details, and a quick-and-dirty  workaround (needs rebuild) there:
> 
> http://nagoya.apache.org/bugzilla/show_bug.cgi?id=17274
> 
> Hope this helps,
> 
> Laurent
> 

Thank you very much for your quick fix.

Do I have to rebuild the whole server or is it enough to do it with
mod_auth_ldap.c ?

Greetings,

Mathias

-- 
+++ GMX - Mail, Messaging & more  http://www.gmx.net +++
Bitte l├Ącheln! Fotogalerie online mit GMX ohne eigene Homepage!


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message